M3 系统不稳定啊

求大神指导,我的M3装的linux系统,换了好几个官方的,都不稳定,操作着,有时候就自己挂了,灯灭了,启动有时候连续好几次才能启动

求官方给点力啊,我用的树莓派从来没出现过这种情况

:$:$:$你保证电源足2A,SD卡class10?

是2A的电源,也是高速卡

下面是串口信息,已经寄回给商家看了:L

?LLO! BOOT0 is starting!
boot0 version : 4.0.0
rtc[1] value = 0x00010000
rtc[2] value = 0x00020000
rtc[3] value = 0x00030000
DRAM DRIVE INFO: V1.1 
DRAM Type =7 (2:DDR2,3:DDR3,6:LPDDR2,7:LPDDR3)
DRAM normal_mode value: 00000001
DRAM CLK =732 MHZ
rsb_send_initseq: rsb clk 400Khz -> 3Mhz
PMU: AXP81X
ddr voltage = 1200 mv
ID CHECK VERSION: V0.2
using ic A83T
using axp AXP813
DRAM zq value: 00003bfb
dram size =2048
card boot number = 2
card no is 2
sdcard 2 line count 8
[mmc]: mmc driver ver 2015-04-13 16:05:39
[mmc]: ***Try SD card 2***
[mmc]: mmc 2 cmd 8 err 00000100
[mmc]: mmc 2 cmd 8 err 00000100
[mmc]: mmc 2 send if cond failed
[mmc]: mmc 2 cmd 55 err 00000100
[mmc]: mmc 2 cmd 55 err 00000100
[mmc]: mmc 2 send app cmd failed
[mmc]: ***Try MMC card 2***
[mmc]: mmc re-update_phase
[mmc]: mmc re-update_phase
[mmc]: 8bit ddr!!! 
[mmc]: mmc re-update_phase
[mmc]: MMC ver 4.5
[mmc]: SD/MMC Card: 8bit, capacity: 7456MB
[mmc]: vendor: Man 00150100 Snr 03b2115a
[mmc]: product: M8G1G
[mmc]: revision: 4.3
[mmc]: ***SD/MMC 2 init OK!!!***
sdcard 2 init ok
The size of uboot is 000d4000.
sum=d800d490
src_sum=d800d490
set_mmc_para,sdly 50M 0
set_mmc_para,sdly 25M 0
Succeed in loading uboot from sdmmc flash.
Ready to disable icache.
Jump to secend Boot.
      0.206]

U-Boot 2011.09-rc1-dirty (Nov 05 2015 - 23:11:51) Allwinner Technology 

      0.214]version: 2.1.0
normal mode
      0.289]pmbus:   normal or secure os
ready
      0.294]PMU: AXP81X
      0.296]PMU: AXP81X found
bat_vol=0, ratio=100
      0.301]PMU: dcdc2 900
      0.304]PMU: pll1 1008 Mhz
AXI0=336 Mhz,PLL_PERIPH =1200 Mhz AHB1=200 Mhz, APB1=100 Mhz 
set power on vol to default
dcdc1_vol = 3300, onoff=1
dcdc2_vol = 900, onoff=1
dcdc3_vol = 900, onoff=1
dcdc4_vol = 900, onoff=1
dcdc6_vol = 900, onoff=1
aldo1_vol = 1800, onoff=0
aldo2_vol = 1800, onoff=1
aldo3_vol = 3000, onoff=1
eldo2_vol = 1800, onoff=0
dldo1_vol = 3300, onoff=0
dldo2_vol = 3300, onoff=0
dldo3_vol = 2500, onoff=1
dldo4_vol = 2800, onoff=0
fldo2_vol = 900, onoff=1
find power_sply to end
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b04, value=0xd, pmu_vol=3300
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b08, value=0xd, pmu_vol=3300
supply=dldo3
axp=axp81x, supply=dldo3, vol=1800
reg addr=0x1c20b0c, value=0x0, pmu_vol=1800
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b10, value=0xd, pmu_vol=3300
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b14, value=0xd, pmu_vol=3300
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b18, value=0xd, pmu_vol=3300
supply=dcdc1
axp=axp81x, supply=dcdc1, vol=3300
reg addr=0x1c20b1c, value=0xd, pmu_vol=3300
supply=aldo3
axp=axp81x, supply=aldo3, vol=3000
reg addr=0x1f02f00, value=0xa, pmu_vol=3000
config gpio bias voltage finish
vbus exist
no battery, limit to dc
ac100 reg 0x00 = 0x101
ac100 reg 0xd0 = 0x0
ac100 reg 0xd1 = 0x0
fel key old mode
run key detect
no key found
no key input
dram_para_set start
dram_para_set end
      0.525]DRAM:  2 GiB
relocation Offset is: 75af9000
gic: normal or no secure os mode
script config pll_de to 504 Mhz
script config pll_video1 to 297 Mhz
Not Found clk pll_video in script 
enable power vcc-hdmi-18, ret=0
DRV_DISP_Init end
      0.686]boot_disp.output_disp=1
      0.689]boot_disp.output_type=3
      0.693]boot_disp.output_mode=5
      0.696]fetch script data boot_disp.auto_hpd fail
disp1 device type(4) enable
attched ok, mgr1<-->device1, type=4, mode=5----
ready to set mode
workmode = 0
MMC:     2
      0.711][mmc]: mmc driver ver 2015-04-13 14:50:00
      0.716][mmc]: get sdc_phy_wipe fail.
      0.720][mmc]: get sdc0 sdc_erase fail.
      0.724][mmc]: get sdc_2xmode ok, val = 1
      0.728][mmc]: get sdc_ddrmode ok, val = 1
      0.732][mmc]: get sdc_f_max fail,use default  50000000Hz
      0.738][mmc]: get card_line ok, card_line = 8
      0.742][mmc]: get sdc_ex_dly_used fail,use default
      0.748][mmc]: SUNXI SD/MMC: 2
      0.761][mmc]: *Try SD card 2*
      0.764][mmc]: mmc 2 cmd 8 err 100
      0.770][mmc]: mmc send if cond failed
      0.774][mmc]: mmc 2 cmd 55 err 100
      0.779][mmc]: send app cmd failed
      0.782][mmc]: *Try MMC card 2*
      0.822][mmc]: mmc re-update_phase
      0.827][mmc]: mmc re-update_phase
      0.832][mmc]: mmc re-update_phase
      0.837][mmc]: ddr8 
      0.839][mmc]: mmc re-update_phase
      0.852][mmc]: CID 0x1501004d 0x38473147 0x4303b211 0x5a6e504f
      0.857][mmc]: MMC ver 4.5
      0.860][mmc]: mmc clk 50000000
      0.863][mmc]: SD/MMC Card: 8bit, capacity: 7456MB
      0.868][mmc]: boot0 capacity: 4000KB,boot1 capacity: 4000KB
      0.874][mmc]: ***SD/MMC 2 init OK!!!***
      0.879][mmc]: erase_grp_size:0x400WrBlk * 0x200 = 0x80000 Byte
      0.885][mmc]: secure_feature 0x55
      0.888][mmc]: secure_removal_type  0x0
      0.892]sunxi flash init ok
the secure storage map is empty
no item name key_burned_flag in the map
sunxi secure storage has no flag
      0.906]usb burn from boot
delay time 0
      0.977]usb prepare ok
      1.779]timer occur
      1.781]overtime
      1.816]do_burn_from_boot usb : no usb exist
limit to dc 
In:    serial
Out:   serial
Err:   serial
--------fastboot partitions--------
-total partitions:11-
-name-        -start-       -size-      
bootloader  : 1000000       1000000     
env         : 2000000       1000000     
boot        : 3000000       1000000     
system      : 4000000       60000000    
misc        : 64000000      1000000     
recovery    : 65000000      2000000     
cache       : 67000000      30000000    
metadata    : 97000000      1000000     
private     : 98000000      1000000     
alog        : 99000000      5000000     
UDISK       : 9e000000      0           
-----------------------------------
base bootcmd=run setargs_nand boot_normal
bootcmd set setargs_mmc
key 0
recovery key high 10, low 8
cant find fstbt value
misc partition found
to be run cmd=run setargs_mmc boot_normal

** Unable to use sunxi_flash 8:0 for fatload **
load file(sn.txt) error 
serial is: 00000000000000000000
mount part name bootloader
cant open script.bin, maybe it is not exist
WORK_MODE_BOOT
board_status_probe
      1.919]pre sys mode
sunxi_bmp_logo_display
      1.957][mmc]: blkcnt should not be 0
      1.975]fetch script data boot_disp.output_disp fail
      1.980]screen_id =1, screen_width =1280, screen_height =720
      1.986]frame buffer address 46400000
      1.990]Hit any key to stop autoboot:  0 
read boot or recovery all
      2.164]sunxi flash read :offset 3000000, 14556211 bytes OK
      2.177]ready to boot
      2.179][mmc]: mmc exit start
      2.191][mmc]: mmc 2 cmd 8 err 100
      2.196][mmc]: mmc send if cond failed
      2.200][mmc]: mmc 2 cmd 55 err 100
      2.205][mmc]: send app cmd failed
      2.217][mmc]: get sdc_phy_wipe fail.
      2.221][mmc]: get sdc0 sdc_erase fail.
      2.225][mmc]: get sdc_2xmode ok, val = 1
      2.229][mmc]: get sdc_ddrmode ok, val = 1
      2.233][mmc]: get sdc_f_max fail,use default  50000000Hz
      2.238][mmc]: get card_line ok, card_line = 8
      2.243][mmc]: get sdc_ex_dly_used fail,use default
      2.248][mmc]: mmc 2 exit ok
      2.251]
Starting kernel ...

[sun8i_fixup]: From boot, get meminfo:
   Start:  0x40000000
   Size:   2048MB
ion_carveout reserve: 96m 128m
ion_reserve_common: ion reserve: [0xb8000000, 0xc0000000]!
ion_cma reserve: 120m 176m 512m
ion_reserve_common: ion reserve: [0xa0000000, 0xc0000000]!
------sun8i_smp_init_ops----37-----
    0.250093] CPU4: failed to boot: -22
    0.290060] CPU5: failed to boot: -22
    0.330060] CPU6: failed to boot: -22
    0.370079] CPU7: failed to boot: -22
    0.815348] config_pmux_para: script_parser_fetch err. 
    0.815848] add_sys_pwr_dm: axp81x_aldo2 ldo already alwayson.
    0.816167] add_sys_pwr_dm: axp81x_aldo2 ldo already alwayson.
    0.816278] add_sys_pwr_dm: axp81x_aldo2 ldo already alwayson.
    1.021733] sunxikbd_script_init: key para not found, used default para. 
    1.055297] sunxi_oops: heming add OOPS_INFO_ADDR = -20
    1.063534] request gpio failed!
    1.387121] init: property_opt_for_mem: start!
    1.392436] init: property_opt_for_mem: ro.sf.lcd_density not set, disable adaptive memory function!
    1.567560] init: /dev/hw_random not found
    1.753502] init: /dev/hw_random not found
[email protected]:/ $     2.532745] failed to get normal led pin assign
    2.537860] failed to get standby led pin assign
    2.863677] [VFE_ERR]vfe sensor register check error at input_num = 0

你最后是怎么解决的